Click here to Skip to main content
15,920,383 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
i do project in vb 2008 use the WIA library. my prog do very well in xp
but in the windows 7 this message appears

Acquire from WIA imaging failed Retrieving the COM class factory for commponent with CLSID
Retrieving the COM class factory for component with CLSID {4EC4272E-2E6F-4EEB-91D0-EBC4D58E8DEE} failed due to the following error: 80040154

what can i do plz
help me
Posted
Updated 20-Jan-13 9:04am
v2
Comments
Sergey Alexandrovich Kryukov 20-Jan-13 14:34pm    
Not enough information.
—SA
Casey Sheridan 20-Jan-13 15:03pm    
Do you have to run it as admin?

1 solution

A quick search seems to suggest this has something to do with the mixture of 32- and 64-bit environments.

These links The Crazy 80040154 COM Class Factory Error[^] and Retrieving the COM class factory for component failed due to the following error: 80040154 [^] suggest changing your platform target from 'Any CPU' to 'X86'.

You can read Visual Studio .NET Platform Target Explained[^] for some information about the project platform.

Try it and see if this solves your problem.
 
Share this answer
 
Comments
SoMad 20-Jan-13 16:09pm    
Good find. The OP did not specify if the Windows 7 is 64 bit, but that is reasonable to assume. I found someone mentioning they had to use WIA2 on Windows 7 systems, but I did not have time to pursue it further.

Soren Madsen

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900