Click here to Skip to main content
15,881,775 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
i am trying to modify a code for forum in V Studio 2008. the code was written in Visual studio 2005. but is getting error, is not able to debug the error. please could any one can help me.

the code is as follows :-

ASP.NET
<%@ Page language="c#" Codebehind="index.cs" AutoEventWireup="false" Inherits="Forum.index" %>
<%@ Register TagPrefix="CC" TagName="Header" Src="header.ascx" %><%@Register TagPrefix="CC" TagName="Pager" Src="CCPager.ascx"%>
<html>
  <head>
    <title>Forum</title>
    <meta name="vs_targetSchema" content="http://schemas.microsoft.com/intellisense/ie3-2nav3-0"/>
    <meta name="CODE_LANGUAGE" content="C#"/>
    <meta http-equiv="pragma" content="no-cache"/>
<meta http-equiv="expires" content="0"/>
<meta http-equiv="cache-control" content="no-cache"/>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/></head>
  <body style="">

  <form method="post"  runat="server">
<CC:Header id="Header"  runat="server"/>
    <input type="hidden" id="p_Messages_message_id"  runat="server" />

<table><tr><td valign="top" >


    <table id="Search_holder"  runat="server" style="border:0; padding:3; width:100%;">

    <tr>
      <td style=" background-color:#f2f2f2;"><font style=" size:2; font:bold; color:#0033cc;"></font></td>
      <td style="">
    <asp:TextBox id="Search_s_topic" Columns="35" MaxLength="50" runat="server"/>

      </td>
      <td >
      <asp:Button
        id="Search_search_button"
        Text="Search"
        runat="server"/>
    </td>
    </tr>
    </table>

</td></tr></table><table><tr><td valign="top" >


    <table   id="Messages_holder"  runat="server" style=" border:0; spacing:1; padding:3; width:100%;">
    <tr><td colspan="6"
        style=" background-color:#c2c2c2;"
><font style=" font:bold" color:#0033cc;"><asp:label id="MessagesForm_Title" runat="server">Discussions</asp:label></font></td></tr>
<tr>
<td style="background-color:#f2f2f2;">
<asp:Label id="Messages_Column_icon" runat="server" Text=""  style=" size:2; font:bold; color:#0033cc;"/></td>

<td style="background-color:#f2f2f2;">
<asp:LinkButton id="Messages_Column_topic" runat="server" Text="Thread" CommandArgument="m.topic" onClick="Messages_SortChange" style=" size:2; font:bold; color:#0033cc;" /></td>

<td style="background-color:#f2f2f2;">
<asp:LinkButton id="Messages_Column_author" Text="Author" CommandArgument="m.author" onClick="Messages_SortChange" style=" size:2; font:bold; color:#0033cc;" runat="server"/></td>

<td style="background-color:#f2f2f2;">
<asp:LinkButton id="Messages_Column_last_modified" Text="Last Modifed" CommandArgument="m.last_modified" onClick="Messages_SortChange" style=" size:2; font:bold; color:#0033cc" runat="server"/></td>

</tr><tr id="Messages_no_records"  runat="server"><td style="" colspan="6"><font style=" size:2;">No records</font></td></tr>
    <tr><td><asp:Repeater id="Messages_Repeater" onitemdatabound="Messages_Repeater_ItemDataBound" runat="server">
    <HeaderTemplate>
    </td></tr>
    </HeaderTemplate>
    <ItemTemplate>
    <tr>
<td style="">
 <asp:Label id="Messages_icon" style=" size:2;" runat="server">  </asp:Label> 
</td>
<td style="">
<asp:HyperLink id="Messages_topic" NavigateUrl="<%# 'viewthread.aspx'+'?'+'mid='+Server.UrlEncode(DataBinder.Eval(Container.DataItem, "m_message_id").ToString()) +'&' +'s_topic=' + Server.UrlEncode(Utility.GetParam('s_topic')) + '&'%>" style=" size:2;" runat="server" value="<%#DataBinder.Eval(Container.DataItem, "m_topic") %>" ></asp:HyperLink> 
</td>
<td style="">
 <asp:Label id="Messages_author" style=" size:2;" runat="server" value="<%# Server.HtmlEncode(DataBinder.Eval(Container.DataItem, "m_author").ToString()) %>"> </asp:Label> 
</td>
<td style="">
<input type="hidden" id="Messages_message_id"  runat="server" value="<%# Server.HtmlEncode(DataBinder.Eval(Container.DataItem, "m_message_id").ToString()) %>"/>
<input type="hidden" id="Messages_smiley_id"  runat="server" value="<%# Server.HtmlEncode(DataBinder.Eval(Container.DataItem, "m_smiley_id").ToString()) %>"/>
 <asp:Label id="Messages_last_modified" style=" size:2;" runat="server" value="<%# Server.HtmlEncode(DataBinder.Eval(Container.DataItem, "m_last_modified").ToString().Replace('T', ' ')) %>" > </asp:Label> 
</td></tr>
</ItemTemplate>
    <FooterTemplate>
    <tr><td>
    </FooterTemplate>
    </asp:Repeater></td></tr>
    <tr><td  style=" background-color:#f2f2f2; colspan:6;">

<asp:LinkButton id="Messages_insert" style=" size:2; color:#0033cc;" runat="server"><img alt="" style=" border:0;" src="images/thread.gif"/></asp:LinkButton>     
<font style=" size:2; color:#0033cc;">
<CC:Pager id="Messages_Pager" style=" size:2; color:#0033cc;" ShowFirst="False" showLast="False" showprev="True" shownext="True"    ShowFirstCaption="" showLastCaption=""  showtotal="False"   showtotalstring="of"    shownextCaption="Next"  showprevCaption="Previous"  PagerStyle="1"  NumberOfPages="10"   runat="server"/>
</font></td></tr>
    </table>


</td>
    </tr></table>


    </form>
</body>
</html>


and is getting error in the tag hyperlink, please any one could help me out. whole of the code can be provided using "email ID" if can help me out with this debugging.
Posted
Updated 19-Jan-12 19:50pm
v2
Comments
Denno.Secqtinstien 20-Jan-12 1:44am    
the actual error is in this code written in side the page :-
<asp:HyperLink id="Messages_topic" NavigateUrl="<%# 'viewthread.aspx'+'?'+'mid='+Server.UrlEncode(DataBinder.Eval(Container.DataItem, "m_message_id").ToString()) +'&' +'s_topic=' + Server.UrlEncode(Utility.GetParam('s_topic')) + '&'%>" style=" size:2;" runat="server" value="<%#DataBinder.Eval(Container.DataItem, "m_topic") %>" > 

thanks
manognya kota 20-Jan-12 2:06am    
what is the error message that you are getting?
Denno.Secqtinstien 1-Feb-12 0:20am    
have you rectified the problem for the given source code. if yes then please share to me.
manognya kota 1-Feb-12 1:13am    
There are few design errors.I guess the errors are clearly displayed.
You have written colspan in the style attribute of a <td>.
<td style=" background-color:#f2f2f2; colspan:6;"> and some errors related to your custom control.
Denno.Secqtinstien 7-Feb-12 7:32am    
Could not find installable ISAM.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.Data.OleDb.OleDbException: Could not find installable ISAM.

i am getting this error while runing the code over firefox did you get the same error for the code provided ?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900