Click here to Skip to main content
14,932,407 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
LIBS += \
    /usr/local/lib/  \

I am getting error with this part that says the file didn't found

ex. cannot open

didn't have any idea what file is this. please help give me idea where i can get the file

What I have tried:

tried research from the internet what could be this file but didn't found any
Updated 14-Sep-18 23:24pm

1 solution

How should we know based on that little information. You even did not provided the error message.

The QtMeshViewer class is not part of the Qt framework. Looks like it is from some kind of project. So you should check the related documentation and/or ask the people from where you got that.

The libraries are probably from the OpenMesh[^] project. If the error message is that the libraries can't be found you have to install them and adjust the path if they have been installed to a different directory and/or are installed with differnt file names (e.g. with version number).
Member 13927363 15-Sep-18 5:24am
i just need to know where i can get the file? do you know?
Jochen Arndt 16-Sep-18 4:07am
You get them by installing the package that contains these libraries if there is one for the Linux distribution used by you.

If not you have to download the sources and build them yourself. How to do that is usually described in the project documentation like at

Member 13927363 17-Sep-18 1:28am
found file but i am getting this error error: LNK1107: invalid or corrupt file: cannot read at 0x16.
Jochen Arndt 17-Sep-18 3:23am
Then you did not have a library file build for your OS / version or the file has been corrupted.

GLU libraries are provided by Linux distributions. Ask Google using your distribution name to know how to install them or check if they are already installed.
Member 13927363 17-Sep-18 4:02am
"Then you did not have a library file build for your OS / version or the file has been corrupted."
is there any way to solved the problem?
Jochen Arndt 17-Sep-18 12:33pm
As I wrote:
By installing the correct libraries. If they are provided for your platform (OS type / version and CPU) you can use those. Otherwise you have to build them from the sources.
Member 13927363 17-Sep-18 22:50pm
i have tried downloading sources from the internet but it gives error 'unresolved external'
Jochen Arndt 18-Sep-18 3:58am
That means that one ore more required libraries are missing. The required libraries (called dependencies) are usually listed in the documentation.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900