Click here to Skip to main content
15,072,735 members

Comments by Member 7763261 (Top 12 by date)

Member 7763261 14-Jun-17 3:49am View
   
I have a work book with 8 sheets, WS = (Excel.Worksheet)WB.Worksheets[3] ; here I am refering to sheet 3, WS.Range["C5", misValue].Value = firstname;
WS.Range["C6", misValue].Value = Surname;
WS.Range["C7", misValue].Value = Tel; the I put some data in some of those ranges. The WS.PrintPreview(); but nothing happens instead it just hangs or opens the first sheet. is there a way around this?
Member 7763261 17-May-17 5:08am View
   
Hi Richard,

Thank you for all your assistance. I have eventually managed to fix the code but I am returning a string instead of a bool. Please share why prefer to return bool instead of string?
Member 7763261 9-May-17 10:27am View
   
Ok the MessageBox.show that I display from my testobj class ? are they in the right place if I want to display to the user what went wrong or are they in the wrong place?
Member 7763261 9-May-17 10:11am View
   
Very, but I have commented out testobj.ReadData(); on btnlogin_Click event and called it on on dowork but I get stuck inside the loop. Any ideas what I might be doing wrong. and thanks for the SQL injection article. very informative.
Member 7763261 9-May-17 9:24am View
   
Yes it is set to true
Member 7763261 9-May-17 8:13am View
   
I have uncommented testobj.ReadData() and also used lblMessage from my testobj class to display messages but the progressbar runs only after. now do I have to declare use progressBar1Value from my testobj class to hold progress as well. because from what I have read I cannot access ui controls from dowork
Member 7763261 9-May-17 1:53am View
   
Hi Richard,

Thank you for your response. Please bare with me as I am new to thing backgroundworker control. It seems like my progressbar only executes after the time consuming code of which I would like to update the progress bar to let the user know that the data is loading. how do I retrieve the result from that e object?
Member 7763261 5-Apr-17 8:42am View
   
I also have this class to make it clear
class myWorkerClass
{

public string Employeename,status;


public int rows = 1;
public int Totrows;
public string connectionString = @"Provider=Microsoft.ACE.OLEDB.12.0;Data Source=D:\IMAC\APP\IMACDB\FormDB.xlsx;Extended Properties='Excel 12.0;HDR=Yes;'";
public OleDbConnection cnn;
public OleDbCommand cmd;
public OleDbDataAdapter da;
public OleDbDataReader dr;
public DataSet dstResults = new DataSet();
public DataView myView = new DataView();
public DataTable dtable;
public DataColumn c;

/*Query strings*/
public string queryString = "SELECT Employee_ID,GID From [Entries$]";
public string countR = "SELECT COUNT(*) FROM [Entries$]";
public string mytables = "Entries$";


}
is there something wrong with my code? where do i set datasource to datagridview
Member 7763261 5-Apr-17 7:33am View
   
When I run the code that using data adpater it jumps to private void backgroundWorker1_RunWorkerCompleted(object sender, RunWorkerCompletedEventArgs e)
{
if (e.Cancelled)
{
toolStripStatusLabel1.Text = "Cancelled by User Intentionally...";
toolStripProgressBar1.Value = 0;
}
// Check to see if an error occurred in the background process.
else if (e.Error != null)
{
toolStripStatusLabel1.Text = e.Error.Message;
}
else
{
// BackGround Task Completed with out Error
//dataGridView1.DataSource = Obj.myView;
toolStripStatusLabel1.Text = " All Records Loaded...";
}
}
This line toolStripStatusLabel1.Text = " All Records Loaded..."; Then the grid is empty and the progressbar also. I am not sure what am i doing wrong.
Member 7763261 7-Mar-17 3:28am View
   
@Arvind Zamakia and @Graeme_Grant Thanks you so much for your assistance. I have managed to fix my query string. Actually the issue was in my Database since I am using excel. All I did was change Employee_ID to text. All is working fine now. Much thanks for assistance.
Member 7763261 3-Mar-17 6:58am View
   
@Graeme_Grant

Thanks for your response. I have removed the extra quotes now I am getting this error "cannot perform like operation on system.double and system.string". The Employee_ID column I would like to convert to string is in a form of numbers from excel sheet as a db. am I converting the right way? Thanks for further assistance.
Member 7763261 1-Oct-12 8:41am View
   
Yes kenneth my question is what am I doing wrong here because the ajax fuction is not posting the query to the relevant php file so that data can be processed i.e This function is not working and I cant peak up why I've tried to trace but I cant find the bug please me where I'm going wrong $.ajax({
type :"POST",
url :"inc/functions.php?action=newagent",
data : query,
success: function(data){
if (data =='Success'){
//setTimeout('proceed()',5000);
alert("Success using Jquery");
}
}});