Start by changing the whole way you write code: refactor your code into separate methods.
For example, your code decides if the user is an employer or an employee, and then act differently. Split that into separate methods: EmployerActivities and EmployeeActivities
This makes the Main function shorter and easier to read:
static void Main(string args)
Console.WriteLine("1 : employer");
Console.WriteLine("2 : employee");
Console.WriteLine("3 : exit");
int operation = int.Parse(Console.ReadLine());
if (operation == 1)
else if (operation == 2)
else if (operation == 3)
And that makes it more obvious that it's already wrong:
1) What happens if the user enters "4" or "5"?
2) Shouldn't it loop round to allow another user?
Then, in both the Employer and Employee code you do the same things: login (which I have to say is very, very badly designed - you give them the damn passwords!) So move login code to a new method, pass it a list of valid logins (for employer and employee as appropriate) and call that from both new methods. Again, your code becomes easier to read, and more reliable as well.
If you are far enough into your course, I'd suggest creating two classes: Employee, and Employer (which derives from Employee) to separate the functions even further.
But ... the really big problem here is that your code doesn't match the question in any way, shape, or form: it's possible that there is a big chunk of question missing but we don't know that.
Then start working on the actual question: take it one bit at a time, and work your way through it. This may help: How to Write Code to Solve a Problem, A Beginner's Guide