Click here to Skip to main content
15,900,973 members
Home / Discussions / C#
   

C#

 
GeneralRe: XML Serialization Pin
rk288120-Dec-11 19:54
rk288120-Dec-11 19:54 
QuestionDatagridView Adds Extra Empty Row Pin
AmbiguousName20-Dec-11 1:07
AmbiguousName20-Dec-11 1:07 
AnswerRe: DatagridView Adds Extra Empty Row Pin
PIEBALDconsult20-Dec-11 4:27
mvePIEBALDconsult20-Dec-11 4:27 
Questionapp working in window Xp but not in window 7 Pin
Hum Dum19-Dec-11 22:44
Hum Dum19-Dec-11 22:44 
AnswerRe: app working in window Xp but not in window 7 Pin
OriginalGriff19-Dec-11 23:03
mveOriginalGriff19-Dec-11 23:03 
GeneralRe: app working in window Xp but not in window 7 Pin
Hum Dum19-Dec-11 23:37
Hum Dum19-Dec-11 23:37 
AnswerRe: app working in window Xp but not in window 7 Pin
Luc Pattyn20-Dec-11 7:03
sitebuilderLuc Pattyn20-Dec-11 7:03 
GeneralRe: app working in window Xp but not in window 7 Pin
Hum Dum8-Jan-12 22:43
Hum Dum8-Jan-12 22:43 
WRT to you link, i tried but no luck.
then i replace hardware card/modem with another one.

And on this everything worked as excepted, without any code modification.
But same old card is working on XP, also responding to hyper-terminal in win 7.

Then i tried SerialPort class of .Net framework 2.0 wrt to this Article and old modem/card responded as excepted in win 7.

I am using this article for PI invoke.

My question is why its not working in win 7 with PI invoke code.
but responding with SerialPort class of .Net 2.0, also to hyper-terminal.
Old modem is PCI card, while new is PCI express.
Any light/idea you shed highly appreciated.

below are query modem log of both old(not working) and new(working)
Not Working Query Modem log
01-06-2012 20:48:20.029 - File: C:\Windows\system32\tapisrv.dll, Version 6.1.7600   
01-06-2012 20:48:20.045 - File: C:\Windows\system32\unimdm.tsp, Version 6.1.7600   
01-06-2012 20:48:20.045 - File: C:\Windows\system32\unimdmat.dll, Version 6.1.7600   
01-06-2012 20:48:20.045 - File: C:\Windows\system32\uniplat.dll, Version 6.1.7600   
01-06-2012 20:48:20.060 - File: C:\Windows\system32\drivers\modem.sys, Version 6.1.7600   
01-06-2012 20:48:20.060 - File: C:\Windows\system32\modemui.dll, Version 6.1.7600   
01-06-2012 20:48:20.060 - File: C:\Windows\system32\mdminst.dll, Version 6.1.7600   
01-06-2012 20:48:20.060 - Modem type: Conexant 56K Voice Modem
01-06-2012 20:48:20.060 - Modem inf path: oem15.inf
01-06-2012 20:48:20.060 - Modem inf section: Modem1
01-06-2012 20:48:20.060 - Matching hardware ID: pci\ven_2003&dev_8800&subsys_280016ef
01-06-2012 20:48:20.060 - Opening the modem device failed with error 00000020
ATQ0V1E0 - OK
AT+GMM - Conexant 56K Voice Modem
       Ver4.20.01AG11
AT+FCLASS=? - 0,1,2.0,8
AT#CLS=? - 0,1,2.0,8
AT+GCI? - +GCI:B5
AT+GCI=? - +GCI:(B5)
ATI1 - Conexant 56K Voice Modem
       Conexant
       Ver4.20.01AG11
       Rev
ATI2 - Conexant 
       Ver4.20.01AG11
       Rev
       MV (CID\SPK)
ATI3 - Conexant
       SL8800 PCI
ATI4 - Active Profile:
       S00=000 S01=000 S02=043 S03=013 S04=010 S05=008 S06=002 S07=060
       S08=002 S09=006 S10=128 S11=100 S12=050 S13=000 S14=000 S15=001
       S16=001 S17=000 S18=000 S19=000 S20=000 S21=000 S22=000 S23=000
       S24=050 S25=000 S26=000 S27=008 S28=000 S29=001 S30=002 S31=001
       S32=092 S33=009 S34=034 S35=000 S36=000 S37=001 S38=000 S39=002
       S40=000 S41=000 S42=000 S43=000 S44=000 S45=250 S46=017 S47=000
       S48=000 S49=000 S50=000 S51=000 S52=000 S53=000 S54=000 S55=000
       S56=004 S57=000 S58=000 S59=000 S60=001 S61=000 S62=001 S63=000
       S64=000 S65=000 S66=000 S67=000 S68=000 S69=000 S70=000 S71=000
       S72=019 S73=003 S74=153 S75=000 S76=004 S77=001 S78=000 S79=070
       S80=070 S81=000 S82=002 S83=055 S84=000 S85=000 S86=000 S87=000
       S88=001 
ATI5 - Stored Profile 0:
       Not defined
ATI6 - Stored Profile 1:
       Not defined
ATI7 - Country: USA
       Serial Number: 0
       Protocol Factor: 0


Working Query Modem log
ATQ0V1E0 - OK
AT+GMM - +GMM: PCIe CX95610 Soft Modem
AT+FCLASS=? - 0,1
AT#CLS=? - COMMAND NOT SUPPORTED
AT+GCI? - +GCI: 53
AT+GCI=? - +GCI: (00,01,02,03,04,05,06,07,09,0A,0B,0C,0D,0E,0F,10,11,12,13,14,15,16,19,1A,1B,1C,1D,1E,1F,20,21,22,
23,24,25,26,27,28,29,2A,2B,2C,2D,2E,2F,30,31,32,33,34,35,36,37,38,39,3A,3B,3C,3D,3E,40,41,42,43,44,45,46,47,48,49,
4B,4C,4D,4E,4F,50,51,52,53,54,55,56,57,58,59,5A,5B,5C,5E,5F,60,61,62,63,64,65,66,67,68,69,6A,6B,6C,6D,6E,6F,70,71,
72,73,74,75,76,77,78,79,7A,7B,7C,7D,7E,7F,80,81,82,83,84,85,86,87,88,89,8A,8B,8C,8D,8E,8F,90,92,93,94,96,97,98,99,
9A,9B,9C,9D,9E,9F,A0,A1,A2,A3,A4,A5,A6,A7,A8,A9,AA,AB,AC,AD,AE,AF,B0,B1,B2,B3,B4,B5,B6,B7,B8,B9,BA,BB,BC,BD,BE,BF,
C1,C2,C3,C4,C5,C7,C8,C9,CA,CB,CC,CD,CE,CF,D0,D1,D2,D3,D4,D5,D6,D7,D8,D9,DA,DB,DC,DD,DE,DF,E0,E1,E2,E3,E4,E5,E6,E7,
E8,EA,EB,EC,ED,EE,EF,F0,F1,F2,F3,F4,F5,F7,F8,F9,FA,FB,FC,FE)
ATI1 - 255
ATI2 - OK
ATI3 - HSF_V7.80.2.51
ATI4 - PCIe CX95610 Soft Modem
ATI5 - 083
ATI6 - SoftK56 
       CModem Version 12
       Rksample Version 342
ATI7 - 255
ATQ0V1E0 - OK
AT+GMM - +GMM: PCIe CX95610 Soft Modem
AT+FCLASS=? - 0,1
AT#CLS=? - COMMAND NOT SUPPORTED
AT+GCI? - +GCI: 53
AT+GCI=? - +GCI: (00,01,02,03,04,05,06,07,09,0A,0B,0C,0D,0E,0F,10,11,12,13,14,15,16,19,1A,1B,1C,1D,1E,1F,20,21,22,
23,24,25,26,27,28,29,2A,2B,2C,2D,2E,2F,30,31,32,33,34,35,36,37,38,39,3A,3B,3C,3D,3E,40,41,42,43,44,45,46,47,48,49,
4B,4C,4D,4E,4F,50,51,52,53,54,55,56,57,58,59,5A,5B,5C,5E,5F,60,61,62,63,64,65,66,67,68,69,6A,6B,6C,6D,6E,6F,70,71,
72,73,74,75,76,77,78,79,7A,7B,7C,7D,7E,7F,80,81,82,83,84,85,86,87,88,89,8A,8B,8C,8D,8E,8F,90,92,93,94,96,97,98,99,
9A,9B,9C,9D,9E,9F,A0,A1,A2,A3,A4,A5,A6,A7,A8,A9,AA,AB,AC,AD,AE,AF,B0,B1,B2,B3,B4,B5,B6,B7,B8,B9,BA,BB,BC,BD,BE,BF,
C1,C2,C3,C4,C5,C7,C8,C9,CA,CB,CC,CD,CE,CF,D0,D1,D2,D3,D4,D5,D6,D7,D8,D9,DA,DB,DC,DD,DE,DF,E0,E1,E2,E3,E4,E5,E6,E7,
E8,EA,EB,EC,ED,EE,EF,F0,F1,F2,F3,F4,F5,F7,F8,F9,FA,FB,FC,FE)
ATI1 - 255
ATI2 - OK
ATI3 - HSF_V7.80.2.51
ATI4 - PCIe CX95610 Soft Modem
ATI5 - 083
ATI6 - SoftK56 
       CModem Version 12
       Rksample Version 342
ATI7 - 255

AnswerRe: app working in window Xp but not in window 7 Pin
Luc Pattyn9-Jan-12 5:17
sitebuilderLuc Pattyn9-Jan-12 5:17 
GeneralRe: app working in window Xp but not in window 7 Pin
Hum Dum9-Jan-12 18:50
Hum Dum9-Jan-12 18:50 
QuestionData Source problem Pin
David baghaturia19-Dec-11 20:13
David baghaturia19-Dec-11 20:13 
AnswerRe: Data Source problem Pin
Jitendra Parida - Jeetu20-Dec-11 1:56
Jitendra Parida - Jeetu20-Dec-11 1:56 
GeneralRe: Data Source problem Pin
David baghaturia20-Dec-11 5:57
David baghaturia20-Dec-11 5:57 
AnswerRe: Data Source problem Pin
AmitGajjar25-Dec-11 22:00
professionalAmitGajjar25-Dec-11 22:00 
GeneralRe: Data Source problem Pin
David baghaturia25-Dec-11 22:46
David baghaturia25-Dec-11 22:46 
QuestionHow to create .chm file that is help file Pin
sarang_k19-Dec-11 17:08
sarang_k19-Dec-11 17:08 
AnswerRe: How to create .chm file that is help file Pin
JF201519-Dec-11 21:17
JF201519-Dec-11 21:17 
AnswerRe: How to create .chm file that is help file Pin
Prasanna Kumar Pete22-Dec-11 0:59
Prasanna Kumar Pete22-Dec-11 0:59 
QuestionAny way to add USER settings at runtime? Pin
SledgeHammer0119-Dec-11 9:59
SledgeHammer0119-Dec-11 9:59 
AnswerRe: Any way to add USER settings at runtime? Pin
fjdiewornncalwe19-Dec-11 10:23
professionalfjdiewornncalwe19-Dec-11 10:23 
GeneralRe: Any way to add USER settings at runtime? Pin
SledgeHammer0119-Dec-11 10:44
SledgeHammer0119-Dec-11 10:44 
Questionhandling network hardwares Pin
Member 825768019-Dec-11 9:52
Member 825768019-Dec-11 9:52 
AnswerRe: handling network hardwares Pin
fjdiewornncalwe19-Dec-11 10:26
professionalfjdiewornncalwe19-Dec-11 10:26 
AnswerRe: handling network hardwares Pin
Subin Mavunkal20-Dec-11 4:32
Subin Mavunkal20-Dec-11 4:32 
QuestionHow to read the SSIS dtsconfig from a c# script Pin
gerom7719-Dec-11 2:30
gerom7719-Dec-11 2:30 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Praise Praise    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.