|
Thanks a lot. I have done that.
|
|
|
|
|
I have a similar requirement, could you please help me how you did this?
|
|
|
|
|
Hi
i'm looking for which how to visual studio generate code when u are working on design mode. for example, suppose u have a web project with visual studio, when u add gridView to yout web page, it generate aspx code in .aspx file on the specific line of page, when u change some default properties of gridView, it add code to .aspx, and when u delete gridView, it delete gridView code that wrote to aspx file. i'm looking for a best way to accomplish this (user design form and my application generate aspx code for it).
can anybody help me ?
thanks
|
|
|
|
|
hdv212 wrote: i'm looking for a best way to accomplish this (user design form and my application generate aspx code for it).
Hi What do you mean,
what do you really expect from others....
i don't get you...!
|
|
|
|
|
Hi jasome
i want when user works in design time and drag & drop a controls on the web page and change it's properties, my application create appropriate aspx code for that.
|
|
|
|
|
hdv212 wrote: i want when user works in design time and drag & drop a controls on the web page and change it's properties, my application create appropriate aspx code for that.
As I suggest below, you have a lot of code to write; none of this happens by magic.
|
|
|
|
|
hdv212 wrote: i'm looking for a best way to accomplish this (user design form and my application generate aspx code for it).
If I understand your question correctly, you want to design an applcation that does the same as Visual Studio. It would allow a user to drag and drop controls onto a form, and your application would generate the actual aspx code, to make it run. This is not a trivial task, IMHO, as you will need to create libaries of classes for all the tools you are to offer, with each class having the properties necessary to generate the images and the code.
|
|
|
|
|
Hi,
I am trying to read emails using c# code..by establishing connection with gmail pop3 server..I receive mails which are in quoted-printable encoded format..how can I decode that..pls help me..
|
|
|
|
|
|
Suddenly not sure which of the following constructs I should go with...
I really like the compactness of B, but a bit unsure how my fellow coders would react to seeing the construct.
I can't see how there should be any performance differences (if you know differently - Do tell)
A:
int i;
switch (ID) {
case "a":
i = 1;
break;
case "b":
i= 2;
break;
case "c":
i = 3;
break;
default:
i = 0;
break;
}
B:
int i;
i = ID == "a" ? 1 :
ID == "b" ? 2 :
ID == "c" ? 3 :
0;
What would you use (and why)?
modified on Tuesday, October 20, 2009 6:46 AM
|
|
|
|
|
Under normal circumstances I would go for the switch - but as it wouldn't work
case "b":
i= 2;
break;
case "b":
i = 3;
break; I would have to fix it first!
The second is horrible - clarity and readability are much more important than saving space on screen.
No trees were harmed in the sending of this message; however, a significant number of electrons were slightly inconvenienced.
This message is made of fully recyclable Zeros and Ones
|
|
|
|
|
The switch, because it's readable and maintainable.
Christian Graus
Driven to the arms of OSX by Vista.
Read my blog to find out how I've worked around bugs in Microsoft tools and frameworks.
|
|
|
|
|
I agree with OriginalGriff.
I'd use switch every time. The conditional operator is fine for small in line statements, but nesting it like that just makes it unreadable too quickly.
The switch is much more readable.
Simon
|
|
|
|
|
Hi,
if it is just one matching you can go with approach 'B'
otherwise i will prefer the First Approach 'A'
because the Second Type has to be parsed as first and process.
and Even if it is more than 2 matching it is not good practice to use 'B'
because it is not much readable and understandable.and for each case we can
make a comment(purpose) in 'A', But it is not suitable for 'B'
but anyway it depends on the place where use, and the situation where you use,and even the appearance where you use
thanks
|
|
|
|
|
It depends on the complexity of the case. I'd definitely avoid the second condition because debugging nested ternary's is an absolute nightmare. In a more complex case than this though, I'd drop both constructs in favour of an Action or Func. Have a look at the Log class in my article here[^] to see how it works.
The basic approach is to set up a set of Actions (or Funcs) that correspond to the operations in your switch statement and assign them to a dictionary (the key in the dictionary is the value for your switch statement). All you need do then is trigger the appropriate action based on the key. In the log sample, this line actually performs the validation:
_actions[level](message);
"WPF has many lovers. It's a veritable porn star!" - Josh Smith As Braveheart once said, "You can take our freedom but you'll never take our Hobnobs!" - Martin Hughes.
My blog | My articles | MoXAML PowerToys | Onyx
|
|
|
|
|
I'll go for Switch because its easy to track errors in that.
|
|
|
|
|
@OriginalGriff
Fixed the switch for ya
clarity and readability are much more important than saving space on screen.
Agreed 100%
Which is why I posted - As the ?: was/is very clear to me, and I can at a glance understand what's going on, but I'm well aware it's not a construct used that/as often, so wanted to test the waters with other coders.
-debugging nested ternary's is an absolute nightmare
-I'll go for Switch because its easy to track errors in that.
Good point
As this is a *very* simple case I didn't even think of that actually.
But it might need to get more complicated as the code evolves.
Where I'm using it, it's not very likely though - But those are "famous last words", so point taken and agreed to.
--
Thank you all for the feed back - I'll tidy up my code now
|
|
|
|
|
As others said switch is more readable in this case. Also when switch has more labels, compilers use a lookup table (probably hash tables) to implement that and it will yield in accessing all the labels in constant time.
Best wishes,
Navaneeth
|
|
|
|
|
The swtich statement is more readable here, but I think in general swtiches give of a bad code smell:clickety[^]
Especially if they are large or used repeatedly.
CCC solved so far: 2 (including a Hard One!)
|
|
|
|
|
In my opinion, a switch on a string value is definitely a code smell. But using if/else or the ternary operator simply to avoid a switch is worse.
|
|
|
|
|
|
No, it's definitely about readability.
|
|
|
|
|
mgkr wrote: What would you use (and why)?
neither, because
1) needing such a conversion often indicates a bad design e.g. a bad choice of data structuring;
2) and when unavoidable, i.e. when I do need to map characters to small positive integers, I use a snippet that is based on "literalString".IndexOf(char)
PS: at least two replies mentioned readability, which does not even appear (any more?) in the OP.
I hate it when the OP gets edited, and yes readability is very important.
Luc Pattyn
I only read code that is properly indented, and rendered in a non-proportional font; hint: use PRE tags in forum messages
Local announcement (Antwerp region): Lange Wapper? 59.24% waren verstandig genoeg om NEEN te stemmen; bye bye viaduct.
|
|
|
|
|
|
Neither.
public enum IDenum { None , a , b , c }
...
IDenum ID = System.Enum.Parse ( typeof(IDenum) , whatever ) ;
(Except I use my own TryParse method.)
|
|
|
|