Click here to Skip to main content
15,885,244 members
Articles / Programming Languages / Java
Technical Blog

Facebook Hacker Cup: "Studious Student" Solution in Java

Rate me:
Please Sign up or sign in to vote.
0.00/5 (No votes)
26 Mar 2013CPOL1 min read 7.6K  
"Studious Student" solution in Java.

This program is a solution to Studious Student problem from Facebook Hacker Cup. The problem can be found here: link.

The problem:

Studious Student

You’ve been given a list of words to study and memorize. Being a diligent student of language and the arts, you’ve decided to not study them at all and instead make up pointless games based on them. One game you’ve come up with is to see how you can concatenate the words to generate the lexicographically lowest possible string.

Input

As input for playing this game you will receive a text file containing an integer N, the number of word sets you need to play your game against. This will be followed by N word sets, each starting with an integer M, the number of words in the set, followed by M words. All tokens in the input will be separated by some whitespace and, aside from N and M, will consist entirely of lowercase letters.

Output

Your submission should contain the lexicographically shortest strings for each corresponding word set, one per line and in order.

Constraints

1 <= N <= 100
1 <= M <= 9
1 <= all word lengths <= 10

Example input

5
6 facebook hacker cup for studious students
5 k duz q rc lvraw
5 mybea zdr yubx xe dyroiy
5 jibw ji jp bw jibw
5 uiuy hopji li j dcyi

Example output

cupfacebookforhackerstudentsstudious
duzklvrawqrc
dyroiymybeaxeyubxzdr
bwjibwjibwjijp
dcyihopjijliuiuy

Java
import java.io.*;
import java.util.Arrays;
public class StudiousStudent 
{
    StudiousStudent(String inputFile) throws IOException, FileNotFoundException
    {
        FileInputStream fis = new FileInputStream(inputFile);
        DataInputStream in = new DataInputStream(fis);
        BufferedReader br = new BufferedReader(new InputStreamReader(in));
        String line = null;
        String splitArray[] = null;
        //Reading the file line by line
        while((line = br.readLine()) != null)
        {
            //Splitting a line from spaces
            splitArray = line.split(" ");
            
            //Initial Sort
            Arrays.sort(splitArray);

            //Advanced Sort
            for (int i = 1; i<splitArray.length; i++)
            {
                for (int j = i+1; j<splitArray.length; j++)
                {
                    if ((splitArray[j].startsWith(splitArray[i])))
                    {
                        if ((splitArray[i]+splitArray[j]).compareTo(splitArray[j]+splitArray[i]) > 0)
                        {
                            String tmp = splitArray[i];
                            splitArray[i] = splitArray[j];
                            splitArray[j] = tmp;
                        }
                    }
                }
            }
            for (int i = 1; i<splitArray.length; i++) System.out.print(splitArray[i]+"");
            System.out.println();
        }
        br.close();
    }
    public static void main(String args[]) throws FileNotFoundException, IOException
    {
        new StudiousStudent("StudiousStudent.txt");
    }
}

Output:

Output for Studious Student

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)


Written By
India India
This member has not yet provided a Biography. Assume it's interesting and varied, and probably something to do with programming.

Comments and Discussions

 
-- There are no messages in this forum --