Click here to Skip to main content
15,354,542 members
Please Sign up or sign in to vote.
1.36/5 (3 votes)
See more:
If anyone has VS2017, mine is broken and won't properly create VSIX projects.

No amount of updates, or even installing VS2019 and using that has worked. Google provides no explanation for the E_INVALIDARG error I'm getting.

Here's what I need: I need an Empty VSIX project, called NewtVS, targeting .NET 4.71 or 4.72 (don't care)

it needs one AsyncPackage in it, called NewtVS.cs

That's it.

If anyone can create that and zip it to a dropbox or something i'd be eternally grateful.

What I have tried:

I've tried creating a VSIX project in visual studio 2017 and adding an AsyncPackage.

I tried doing the same thing in visual studio 2019, same error message.

This used to work for me.
Updated 6-Jun-19 21:55pm
lmoelleb 5-Jun-19 9:16am
Looks more like something for the forum than the Q&A section. So consider asking in there.
honey the codewitch 5-Jun-19 9:35am

1 solution

I found a workaround by copying the one project it created that worked, renaming all of it, and then generating new guids for the package/product stuff

it's not ideal, but it works.
[no name] 7-Jun-19 5:16am
Thanks a lot

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900