Click here to Skip to main content
15,118,573 members
Please Sign up or sign in to vote.
3.00/5 (2 votes)
See more:
Hello,

I"ve created an ActiveX control and added it into my Web application. When I run the application using Microsoft Developers Environment(Default Web Server) the application works fine and also the ActiveX control.

When I Host the application on IIS on the same machine the application works fine but the ActiveX control doesn't appear nor gives any error. This gives me an indication that there is something wrong with IIS settings for ActiveX. Because same page works fine when not hosted on IIS and when you host it on IIS it stops displaying ActiveX.

Even I deployed the same application on another machine which had IIS installed previously it worked fine on that machine as well. But when I tried to access the application from another machine the same problem appeared.
Posted
Updated 28-Feb-11 5:40am
v3
Comments
coolestCoder 28-Feb-11 6:58am
   
Have you checked any warning messages displayed in the browser when trying to access the link ? Maybe the browser is blocking the activeX ?

1 solution

Try granting ACTIVEX's rights to 'Distributed COM users' .
   
Comments
Murali.P 28-Feb-11 23:02pm
   
Hi ,

Thank you for posting answer,please suggest me where i can grant the permissions to distributed Com Users.

thanks.
Piccadilly Yum Yum 1-Mar-11 4:10am
   
Right click on activex -> properties -> protection

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900